permissions problem

You can ask general questions, share opinions or advices about FBackup
svanetempest
Posts: 6
Joined: Sun Jan 07, 2018 3:36 pm

permissions problem

Postby svanetempest » Sun Jan 07, 2018 4:09 pm

Hi.
I have been using FBackup since version 4 without any issues,
Imagine my surprise when setting up 2x Windows 10 PCs and restoring backed up date to find the permissions all messed up.
My NAS being used is a QNAP.
If I drah and drop a folder(s) to the new PC, permissions are all OK.
If I use FBackups restore function (same path, drive letter etc), most permission sget removed and even as the logged in user I have no rights, even though I am shown as the 'owner' of the files/folders.
The two screen images show the same exact file/directory on Windows 10 - one copied from theNAS using Explorer and the other my FBackups Restore function.
Explorer Move.jpg
Explorer Move.jpg (36.92 KiB) Viewed 6629 times

Explorere Move active user permissions.jpg
Explorere Move active user permissions.jpg (34.95 KiB) Viewed 6629 times

FBackup-Restore.jpg
FBackup-Restore.jpg (34.85 KiB) Viewed 6629 times

I hope someone can shed light on this? Obviously, for program files this is completely useless. Also, I tried changing child permissions which failed.
Thanks,
Just tested on an old win7 PC with V4 and that has the same symptoms....

Softland
Posts: 1548
Joined: Thu May 23, 2013 7:57 am

Re: permissions problem

Postby Softland » Tue Jan 09, 2018 8:36 am

Hi,

Did you used the Mirror backup type with the option to copy NTFS permissions?

svanetempest
Posts: 6
Joined: Sun Jan 07, 2018 3:36 pm

Re: permissions problem

Postby svanetempest » Tue Jan 09, 2018 10:57 am

Hi.
Unfortunately some of the older backups were from a PC with FAT partitions.
My question I guess is, more specifically, how can permissions be given to 'restored' files other than simple read and write to everyone? I am puzzled as to why FBackup does not allow the option for the current user to have their permissions put on the restored files?
In the case of all my master software utilities, these cannot be run once restored due to insufficient permissions.
In the case of thousands of photos, I cannot just copy or drag and drop back to the hard disk as this destroys all the original file creation/modified data.
Interestingly, I did notice that when there was a directory tree, all the directories preceding the one containing the files to be restored all the correct users/administrators,authenticated users in the security tab.
It is only the 'final' directory containing files that has the users listed as everyone, S-1xxxxxx etc, and with just 'special' permissions in this way.
The files in the final directory have just read and write permissions for 'everyone' and the strange users listed in the image below.
2018-01-09_104818.jpg
2018-01-09_104818.jpg (32.35 KiB) Viewed 6617 times


Looking at a specific image file 'restored' shows the following;

2018-01-09_105139.jpg
2018-01-09_105139.jpg (35.52 KiB) Viewed 6617 times


The owner is shown as Administrators (this pc) and the user logged in also has administrator rights.
All very puzzling.

I like FBackup and do not want to change, but I found that a simpler software, NetBack Replicator, did not seem to mess with the permissions.

Any ideas? Is there a registry setting in FBackup that may over ride this behaviour?

Thanks.

svanetempest
Posts: 6
Joined: Sun Jan 07, 2018 3:36 pm

Re: permissions problem

Postby svanetempest » Wed Jan 10, 2018 1:00 pm

After a bit more testing, interestingly Microsoft have a small utility called RichCopy which will copy selected directories from the QNAP NAS to 'any' windows PC (if user is correctly logged in) with all the permissions.

Is anyone from FBackup able to comment on this odd behaviour when trying to 'restore' files from a QNAP NAS so that the user logged onto the PC running FBACKUP has the security privileges restored?

I am happy to upgrade to Backup4all if this will sort the issues.

Thanks.

Softland
Posts: 1548
Joined: Thu May 23, 2013 7:57 am

Re: permissions problem

Postby Softland » Thu Jan 11, 2018 12:46 pm

Hi,

We were able to reproduce the problem and we will fix it.

svanetempest
Posts: 6
Joined: Sun Jan 07, 2018 3:36 pm

Re: permissions problem

Postby svanetempest » Thu Jan 11, 2018 2:23 pm

Great - Thanks.
As a final question, when restoring files, are the original created and modified dates preserved? I think this is not possible with directories, but for obvious reasons photos without exif data need their original creation and modified dates preserved.
Many thanks.

Softland
Posts: 1548
Joined: Thu May 23, 2013 7:57 am

Re: permissions problem

Postby Softland » Fri Jan 12, 2018 10:56 am

Hi,

The original data is restored for both files and folder. For folders, if they contain other subfolders or files, it will be changed during the restore time because of the modifications, as you assumed. For files, the restored original data remains.

svanetempest
Posts: 6
Joined: Sun Jan 07, 2018 3:36 pm

Re: permissions problem

Postby svanetempest » Thu Jan 18, 2018 3:21 pm

Hi,
I appreciate that you will have QA test and sign off processes, but do you have a possible ETA for the 'fix' to FBackup for the permissions issue you managed to reproduce?
Just that I have several new PCs at home to migrate data to from existing backups and it would be great to be able to roughly plan when I can restore data correctly.
Many thanks,
Stewart

svanetempest
Posts: 6
Joined: Sun Jan 07, 2018 3:36 pm

Re: permissions problem

Postby svanetempest » Wed Jan 24, 2018 4:23 pm

Thanks - all sorted with the latest release.
All Samba permissions etc now work correctly on a restore operation. Now restoring old backups to a new PC.
Thank you for the fast resolution.

Softland
Posts: 1548
Joined: Thu May 23, 2013 7:57 am

Re: permissions problem

Postby Softland » Mon Jan 29, 2018 11:31 am

Hi,

The problem was fixed.


Return to “General”